Russian TYPO3 community Форум больше не используется. Присоединяйтесь к каналу #community-ru в Slack for TYPO3 community  

Вернуться   Russian TYPO3 community > Обсуждение общих технических вопросов > FAQ (Часто задаваемые вопросы)

Ответ
 
Опции темы Опции просмотра
Старый 02.02.2009, 05:28   #21
Yarche
Новенький
 
Регистрация: 27.01.2009
Сообщений: 13
По умолчанию

Всем вечер добрый!
Накопилось несколько вопросов.
Я скачал и разпаковал "wec_starter-4_2_3-1_0_0_fullserver.zip",
запустил http://localhost:4001/phpmyadmin/ создал новую базу "utf8_unicode_ci".
затем очистил папку "htdocs" и перезалил в неё "wec_starter-4_2_3-1_0_0" для стандартной установки на UNIX-вый сервер с предустановленными данными.

В админке "редактор страниц" сначала вылетало предупреждение "Warning.......................2308"

Пропатчил файл "class.t3lib_div.php" он почему то патчится с ошибками.

В админке вылетает новая ошибка "Warning: xml_parser_set_option() [function.xml-parser-set-option]: Unsupported target encoding "windows-1251" in e:\and-you.su\CMS\typo\UTF8\htdocs\t3lib\class.t3lib_div. php on line 2309"

Честно говоря это предупреждение закрывает пол экрана и не даёт возможности сохранять изменения так как елементы страницы накладываются друг на друга.

И ещё интересное наблюдение База данных у меня UTF8 а браузер в котором просматриваю сотворённое - кирилические символы отображает только в Win-1251.

Версии:
Typo3 4.2.3
PHP 5.1.4
Apache 1.3.35
CGI 1.1
MySQL 4.1.7
Yarche вне форума   Ответить с цитированием
Старый 02.02.2009, 12:38   #22
Valery Romanchev
Administrator
 
Аватар для Valery Romanchev
 
Регистрация: 23.08.2003
Адрес: Moscow, Russia
Сообщений: 1,926
Отправить сообщение для Valery Romanchev с помощью Skype™
По умолчанию

Цитата:
Сообщение от Yarche Посмотреть сообщение
Всем вечер добрый!
Накопилось несколько вопросов.
Я скачал и разпаковал "wec_starter-4_2_3-1_0_0_fullserver.zip",
запустил http://localhost:4001/phpmyadmin/ создал новую базу "utf8_unicode_ci".
затем очистил папку "htdocs" и перезалил в неё "wec_starter-4_2_3-1_0_0" для стандартной установки на UNIX-вый сервер с предустановленными данными.

В админке "редактор страниц" сначала вылетало предупреждение "Warning.......................2308"

Пропатчил файл "class.t3lib_div.php" он почему то патчится с ошибками.

В админке вылетает новая ошибка "Warning: xml_parser_set_option() [function.xml-parser-set-option]: Unsupported target encoding "windows-1251" in e:\and-you.su\CMS\typo\UTF8\htdocs\t3lib\class.t3lib_div. php on line 2309"

Честно говоря это предупреждение закрывает пол экрана и не даёт возможности сохранять изменения так как елементы страницы накладываются друг на друга.

И ещё интересное наблюдение База данных у меня UTF8 а браузер в котором просматриваю сотворённое - кирилические символы отображает только в Win-1251.

Версии:
Typo3 4.2.3
PHP 5.1.4
Apache 1.3.35
CGI 1.1
MySQL 4.1.7
помоему Вам не надо ничего патчить и не надо вообще читать эту ветку - она не касается Вашей ситуации
__________________
Веб-студия ТТЛАБ
www.ttlab.ru
Valery Romanchev вне форума   Ответить с цитированием
Старый 02.02.2009, 21:14   #23
Yarche
Новенький
 
Регистрация: 27.01.2009
Сообщений: 13
По умолчанию

Спасибо.
Но ведь ошибка в админке присутствует в любом случае

В админке вылетает новая ошибка "Warning: xml_parser_set_option() [function.xml-parser-set-option]: Unsupported target encoding "windows-1251" in e:\and-you.su\CMS\typo\UTF8\htdocs\t3lib\class.t3lib_div. php on line 2308"

И так и не ясен вопрос с кодировкой

База данных у меня UTF8 а браузер в котором просматриваю сотворённое - кирилические символы отображает только в Win-1251.
Yarche вне форума   Ответить с цитированием
Старый 02.02.2009, 21:16   #24
Yarche
Новенький
 
Регистрация: 27.01.2009
Сообщений: 13
По умолчанию

Должен поправиться ошибка появляется в руссифицированном варианте админки.
Yarche вне форума   Ответить с цитированием
Старый 04.02.2009, 01:29   #25
Falcon
Продвинутый
 
Регистрация: 09.10.2008
Сообщений: 77
По умолчанию

Цитата:
Сообщение от Yarche Посмотреть сообщение
Пропатчил файл "class.t3lib_div.php" он почему то патчится с ошибками.
мне кажется в этом твоя проблема.

у меня было тоже самое (патчился ошибками.) моё решение описано на предидущей странице
Falcon вне форума   Ответить с цитированием
Старый 27.01.2010, 01:38   #26
garik
Новенький
 
Регистрация: 21.03.2006
Сообщений: 13
По умолчанию

спасибо за патч, все исправилось)
garik вне форума   Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB code is Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Часовой пояс GMT +4, время: 23:44.


Работает на vBulletin® версия 3.8.1.
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Перевод: zCarot

Хостинг и техническая поддержка: TYPO3 Лаборатория